Tails 4.8 will ship with an persisting option to disable the so called "Unsafe Browser".

The Unsafe Browser exists to access captive portals.

Unfortunately this is also an attack surface.
To everyone who is using public internet access points is the "Unsafe Browser" an essential tool. Just getting rid of that function would be a decision against those needing Tails probably the most.

Tails will instead minimizing more of the attack surface.

Tails 4.8 is scheduled for 2020-06-30.

Follow

@tails

Thanks!
Getting rid of it would be bad, Tails already have ALOT of warnings that it is indeed an unsafe browser. But keeping it optional is awesome!

Β· Β· Web Β· 0 Β· 0 Β· 2
Sign in to participate in the conversation
Linux.Pizza

A instance dedicated - but not limited - to people with an interest in the GNU+Linux ecosystem and/or general tech. Sysadmins to enthusiasts, creators to movielovers - Welcome!